BGP Métrique: Le Weight

Salut à tous ! On reprend la série BGP : on s’attaque à la métrique et on va parler du Weight (le poids).

Qu’est ce que le weight ?

Le weight est le premier attribut BGP comme vous pouvez le voir dans le tableau ci-dessous :

Source : https://www.networklab.fr/wp-content/uploads/2013/09/M%C3%A9trique-de-BGP.png

Le weight (poids) comme son nom l’indique permet de favoriser un voisin (BGP) par rapport à un autre. Exemple : j’ai un router A connecté au routeur B et au routeur C comme ci-dessous :

J’ai 2 chemins pour accéder à la même route, si je configure un poids à 100 sur le routeur B et un poids à 200 sur le routeur C, alors le routeur A passera par le routeur C pour accèder au réseau.

C’est tout simplement cela le weight 🙂 .

Remarques importantes :

  • La configuration est faite en local sur le routeur
  • Cette métriques n’est pas annoncée au routeur voisin
  • La métrique est par défaut à 0

Passons au LAB :

Vidéo Youtube :

Schéma :

Le but du LAB : faire passer les flux de Marseille vers LibreNMS qui passe initialement par Bordeaux et les faire passer par Nantes en mettant un poids supérieur au niveau de la configuration BGP.

Voici les confs des différents routeurs :

MARSEILLE :

MARSEILLE#show running-config 
Building configuration...

Current configuration : 1576 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname MARSEILLE
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
ip dhcp pool CLIENT_LAN
 network 192.168.70.0 255.255.255.0
 default-router 192.168.70.1 
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!         
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 media-type gbic
 speed 1000
 duplex full
 negotiation auto
!
interface GigabitEthernet1/0
 ip address 50.54.30.1 255.255.255.252
 negotiation auto
!
interface GigabitEthernet2/0
 ip address 43.200.10.1 255.255.255.252
 negotiation auto
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet4/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet5/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet6/0
 ip address 192.168.70.1 255.255.255.0
 negotiation auto
!
router bgp 111
 bgp log-neighbor-changes
 network 192.168.70.0
 neighbor 43.200.10.2 remote-as 777
 neighbor 43.200.10.2 weight 100
 neighbor 50.54.30.2 remote-as 444
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

BORDEAUX:

BORDEAUX#show running-config 
Building configuration...

Current configuration : 1504 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname BORDEAUX
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
!
!
!
!         
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 media-type gbic
 speed 1000
 duplex full
 negotiation auto
!
interface GigabitEthernet1/0
 ip address 50.54.30.2 255.255.255.252
 negotiation auto
!
interface GigabitEthernet2/0
 ip address 187.18.20.2 255.255.255.0
 negotiation auto
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet4/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet5/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet6/0
 no ip address
 shutdown
 negotiation auto
!
router bgp 444
 bgp log-neighbor-changes
 network 187.18.20.0 mask 255.255.255.0
 neighbor 50.54.30.1 remote-as 111
 neighbor 187.18.20.1 remote-as 999
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
ip prefix-list NY_BOR seq 5 permit 187.18.20.0/24
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

NANTES:

NANTES#show running-config 
Building configuration...

Current configuration : 1452 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname NANTES
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
!
!
!
!         
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 media-type gbic
 speed 1000
 duplex full
 negotiation auto
!
interface GigabitEthernet1/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet2/0
 ip address 43.200.10.2 255.255.255.252
 negotiation auto
!
interface GigabitEthernet3/0
 ip address 150.90.40.2 255.255.255.0
 negotiation auto
!
interface GigabitEthernet4/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet5/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet6/0
 no ip address
 shutdown
 negotiation auto
!
router bgp 777
 bgp log-neighbor-changes
 network 150.90.40.0 mask 255.255.255.0
 neighbor 43.200.10.1 remote-as 111
 neighbor 150.90.40.1 remote-as 999
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

NEW YORK :

NEW_YORK#show running-config 
Building configuration...

Current configuration : 1536 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname NEW_YORK
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
ip dhcp pool WAN_NY
 network 192.168.90.0 255.255.255.0
 default-router 192.168.90.1 
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!         
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 media-type gbic
 speed 1000
 duplex full
 negotiation auto
!
interface GigabitEthernet1/0
 no ip address
 shutdown 
 negotiation auto
!
interface GigabitEthernet2/0
 ip address 187.18.20.1 255.255.255.0
 negotiation auto
!
interface GigabitEthernet3/0
 ip address 150.90.40.1 255.255.255.0
 negotiation auto
!
interface GigabitEthernet4/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet5/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet6/0
 ip address 192.168.90.1 255.255.255.0
 negotiation auto
!
router bgp 999
 bgp log-neighbor-changes
 network 192.168.90.0
 neighbor 150.90.40.2 remote-as 777
 neighbor 187.18.20.2 remote-as 444
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

Ensuite nous allons configurer le weight sur Marseille :

router bgp 111
neighbor 43.200.10.2 weight 100

Comme on peut le voir dans la vidéo les flux passent désormais par NANTES.

Merci à vous, n’hésitez pas à vous abonnez et à commenter la vidéo !

1. Prendre la main sur une VM fortigate : Mettre une ip fixe en CLI.

Bonjour à tous je reviens après un petit moment d’absence sur mon blog.

Nous allons attaquer un nouveau domaine : la sécurité !!!

Plus précisément le firewalling avec le produit Fortigate, un firewall créé par la société Fortinet (société américaine) spécialisée dans les équipements de sécurité réseau.

Voici le lien de ma vidéo Youtube :

Dans ce lab on va importer le fichier OVF avec une VM Fortigate puis configurer une IP en CLI.

Prérequis :

  • VMWare Workstation (ou VirtualBox)
  • Se procurer le fichier OVF fortigate en faisant une demande directement à Fortigate ou à un partenaire Forti.

Contexte : On utilisera VMWare Workstation dans ce lab; vous pourrez adapter si besoin est à VirtualBox (une vidéo sera peut être faite avec VirtualBox pour authentification AD avec Forti)

Tout d’abord importer le fichier OVF sur VMWare Workstation en cliquant sur « Open a Virtual Machine » :

J’accepte le contrat de licence :

Je fournis un nom et l’emplacement où sera enregistré la VM :

Ma VM est bien importée 🙂

Avant de la démarrer, je vais m’assurer que l’interface numéro 1 est bien en bridge en regardant dans les settings (les autres interfaces ne nous intéresse pas pour le moment).

PS : Normalement toutes les interfaces sont en bridge.

Je démarre ensuite la VM :

ATTENTION !!! On est en QWERTY

Login : admin

et pas de mot de passe (taper juste sur la touche ENTREE)

Astuce pour le login taper: qd,in

On configure l’interface port1 :

config system interface
  edit port1
  set mode static
  set ip 192.168.1.111 255.255.255.0 

On est toujours en QWERTY mais vous arriverez à vous débrouiller avec la tabulation.

je tape :

end

Et ensuite je vérifie ma conf :

show system interface

Mon interface est bien configuré. Je peux désormais accéder en WEBGui à mon Fortigate :

Login comme en CLI « admin » et sans mots de passe. Et cette fois vous pourrez écrire en AZERTY 😀 .

A bientôt pour de nouveau tutos sur Fortigate et d’autres sujets 🙂 !